Rebooting the Subaru Impreza 2017 Infotainment System

A few months ago in my post about a year with my 2017 Subaru Impreza, I mentioned that sometimes CarPlay doesn’t start. This is annoying and I thought the problems were gone with the recents updates. However, last Saturday it didn’t start again and I actually needed the navigation to get somewhere. I had read that opening and closing the door 3 times would reboot the car, but it didn’t work. I could wait 10 minutes, but I had to leave. That left me without navigation but luckily my son was able to use an iPad connected to my hotspot to navigate.

After this episode, I started looking for the real answer to rebooting the infotainment system. I searched and searched and found on a forum (can’t find the reference right now) that if you press and hold the power button for the radio until it shuts off and then for another 10 seconds, the unit restarts. I found this hard to believe, but went out to my car and tried it out. It actually worked! Now I had a potential workaround the next time I had a problem.

Yesterday I plugged in my phone as normal and CarPlay didn’t start. I pushed and held the power button to reset the unit. Once it was up again, I reconnected my phone and presto, it worked! This definitely should be documented somewhere as it is extremely convenient. Let’s hope that a software update doesn’t remove this functionality.

5 Replies to “Rebooting the Subaru Impreza 2017 Infotainment System”

  1. Different but related subject:

    Every time I plug my phone into my wife’s Honda CR-V with CarPlay, music plays automatically. Happens with my wife’s iPhone as well.

    I tried force quitting the music app but it still does it.

    Ideas?

    1. Was music paused on your phone before plugging it in? If so, try stopping it and see if the behavior changes. I’ve only seen this if I had music paused and plugged in my phone, I think.

        1. That’s strange. I would think that this is controlled by CarPlay so I’m not sure why my situation would be different than yours. You might want to check with the dealer to see if they’ve heard of this issue. Keep me posted if you find a solution.

          1. I’ve tried everything on both the iPhone/iOS and in the Honda dash with its setup. Still auto-playing.

            I read online that many people are having this issue although across various applications, not just with iTunes. One would think Apple would have a solution but alas, they don’t.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.